PHP Selector - Αλλάζοντας έκδοση php, ρυθμίσεις και modules Εκτύπωση

  • 1

Χρειάζεται να συνδεθείτε σε MS-SQL server και δεν υπάρχει το αντίστοιχο module για mssql ?
Χρησιμοποιείτε ImageMagick αλλά έχουμε ενεργοποιημένο μόνο το GD ?
Κάποια σελίδα απαιτεί Register Globals σε On αλλά είναι σε Off ? 
Κάποια άλλη ίσως χρειάζεται PHP έκδοση 5.2 ή 5.4 και ο server τρέχει σε 5.3;

Με το php selector μέσα από το cPanel μπορείτε να αλλάξετε έκδοση PHP, Modules και ρυθμίσεις όπως ακριβώς τα θέλετε.


1ο βήμα.

Μέσα στο cPanel διαλέγετε από τη καρτέλα Software/Services το εικονίδιο Select PHP Version

phpselector cpanel



2ο βήμα.

Μέσα θα δείτε τις εξής επιλογές:
version select

Ξεκινάτε με την έκδοση PHP που θέλετε.
Native σημαίνει να χρησιμοποιήσει το cpanel την έκδοση που τρέχουμε εμείς. Αν θέλετε για παράδειγμα 5.3 την επιλέγετε και θα ανοίξουν οι ρυθμίσεις για την 5.3.



3ο βήμα.

php modules

Διαλέγετε τα modules που θέλετε να χρησιμοποιήσετε με την 5.3 και πατάτε πρώτα "Save" και μετά "Set as current".
Modules που χρειάζονται αναλόγως τη βάση είναι πχ mysql, mysqli.
Για γραφικά gd και Imagemagick.
Σε περίπτωση που θέλετε κάποιο μηχανισμό cache μπορείτε πχ να ενεργοποιήσετε modules όπως xcache κ.ο.κ.

Οι αλλαγές συμβαίνουν live οπότε αν κάτι ξεχάσατε απλά πάτε στο select php version και τσεκάρετε την επιλογή που ίσως ξεχάσατε.
Η αλλαγή θα φανεί εκείνη τη στιγμή.




4ο βήμα.

Μόλις αλλάξατε έκδοση php και βάλατε τα modules που θέλατε. Αν θέλετε να αλλάξετε ρυθμίσεις όπως 
register globals, allow url include, memory limit, timeouts κ.ο.κ συνεχίζετε πατώντας στο κουμπί "Show PHP Settings" πάνω δεξιά.
Θα εμφανιστεί αυτό:
show php settings

από εδώ μπορείτε να αλλάξετε ότι ρυθμίσεις ίσως επηρεάζουν κάποιο CMS*.

*Παράδειγμα οι νέες εκδόσεις Joomla 3.x χρειάζονται το magic_quotes_gpc στο On για να δουλέψουν.

Πατάτε save και είναι όλα έτοιμα.


Ήταν χρήσιμη αυτήν την απάντηση;

« Πίσω